YOUR SECURITY IS OUR PRIORITY

If your browser is compatible, you will receive a message stating: "Your user agent has good protocol support."

  You're all set!

If your browser is not compatible, you will receive a message stating: "Your user agent doesn't support TLS 1.2.  You should upgrade. "  Please upgrade your browser to the latest version.

As of August 19, 2017, ASC's Webcast System has been upgraded to a higher level of security. To test your browser's compatibility, please click here: https://www.ssllabs.com/ssltest/viewMyClient.html. Once you click the link, the Compatibility Test typically takes less than 5 seconds.

SCREENSHOTS


If you have any questions regarding the Compatibility Test, please see the screenshots below and/or contact ASC Support at support@asc-net.com or 800-950-2082 ext. 2.

If your browser is compatible, you will see this:

If your browser is not compatible, you will see this:

For assistance with upgrading your browser or compatibility questions, contact the ASC Support Team at 888-950-2082 ext. 2 or email us at support@asc.com.